pkgsrc-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: pkg/45433 (security/cyrus-sasl does not compile on Solaris with lang/gcc34)

  It does not appear that the package has been changed since 2 weeks
  ago... my first attempt to reproduce this failed... but I have gcc
  4.4.5 on
  Oracle Solaris 10 9/10 s10x_u9wos_14a X86 (You don't mention your os
  version) I don't think the compiler difference would matter in this

i86: 5.10 Generic_142901-03
sparc: 5.10 Generic_142900-03

I'm pretty sure it's the compiler/linker combination, because of "text relocation" problems.

  (I also did not start with a clean bootstrap, did you?)  any other config 
  Any idea what else than pkgsrc might have changed?  if it is only
  pkgsrc can you pinpoint more closely the time when it last worked and
  first failed?

The last working version was installed 2011-09-08, the pkgsrc tree was synced around that time as well.

BTW: Even with "bmake SASL_DBTYPE=berkeley", I can't build the package on sparc. The command lines libtool generates for building are identical on both architectures, but on i86 the build succeeds, on sparc it fails. I don't see any differences in the generated config.log files. I suspect a regression in libtool.

 Jörn Clausen                    
 Universität Bielefeld

Home | Main Index | Thread Index | Old Index