pkgsrc-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: pkg/44991: [maintainer update] devel/ocaml-lwt to 2.3.0

The following reply was made to PR pkg/44991; it has been noted by GNATS.

From: Jaap Boender <>
Subject: Re: pkg/44991: [maintainer update] devel/ocaml-lwt to 2.3.0
Date: Wed, 27 Jul 2011 16:11:44 +0200

 >  I looked at the Makefile, and
 >          ${RM} -rf ${DESTDIR}${PREFIX}/lib/ocaml/site-lib
 >  is a bit harsh -- if you install without destdir, this blows away any
 >  other files installed there. Are you sure you want this?
 Well, the point is that the package won't (re)install if the old version is 
 still installed, so the old version *does* need to be removed. I've modified 
 to remove only the old ocaml-lwt directory, this should be less of a problem.
 >  Please try to fix the other pkglint warnings as well, especially the
 >  dependency problem :)
 This has been done, as far as I can: I'm not sure that using AUTO_MKDIRS 
 solves my problem, and I can't add the 'toplevel' option to by 
 myself :) 
 The ocaml-react package I have submitted as pkg/45814, with apologies, I 
 thought I'd already done that.

Home | Main Index | Thread Index | Old Index