pkgsrc-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

pkg/45064: mail/dovecot2 should alert to restart the service - patch attached

>Number:         45064
>Category:       pkg
>Synopsis:       mail/dovecot2 need to be restarted when upgraded. User should 
>be alerted
>Confidential:   no
>Severity:       non-critical
>Priority:       low
>Responsible:    pkg-manager
>State:          open
>Class:          change-request
>Submitter-Id:   net
>Arrival-Date:   Wed Jun 15 08:55:00 +0000 2011
>Originator:     Stefano Marinelli
>Release:        NetBSD 5.1_STABLE
System: NetBSD 5.1_STABLE NetBSD 5.1_STABLE (DOMU_DRAGAS) #9: Thu Jun 
2 07:52:32 UTC 2011 amd64
Architecture: x86_64
Machine: amd64
        mail/dovecot2 has two components: a backend and a worker. The worker is 
launched every time a connection is started, while the backend sits and waits.
        When upgrading, a version mismatch between the two occurs and the 
backend refuses any connection from the worker because of it. User should be
        alerted, so I just added a couple of lines to the "MESSAGE" file.
        Upgrade mail/dovecot2 from a lower (minor) version.
        Restarting Dovecot2 after any upgrade. At least, user should be alerted 
(patch follows):

--- dovecot2.orig/Makefile      2011-06-15 08:38:00.000000000 +0000
+++ dovecot2/Makefile   2011-06-15 08:40:52.000000000 +0000
@@ -1,7 +1,7 @@
 # $NetBSD: Makefile,v 1.12 2011/06/10 21:57:08 obache Exp $
 DISTNAME=      dovecot-2.0.13
 CATEGORIES=    mail
--- dovecot2.orig/MESSAGE       2011-06-15 08:38:00.000000000 +0000
+++ dovecot2/MESSAGE    2011-06-15 08:40:11.000000000 +0000
@@ -11,4 +11,7 @@ When upgrading from Dovecot 1.2.x, you c
 For more information, see
+Please, remember to restart Dovecot after any upgrade. Otherwise, it will
+complain about a version mismatch and refuse any connection.

Home | Main Index | Thread Index | Old Index