pkgsrc-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: pkg/39890: ruby 1.8.6 not available in pkgsrc

The following reply was made to PR pkg/39890; it has been noted by GNATS.

From: David Holland <>
Subject: Re: pkg/39890: ruby 1.8.6 not available in pkgsrc
Date: Mon, 13 Jun 2011 01:49:37 +0000

 On Wed, Dec 03, 2008 at 01:00:26AM +0100, Michal Suchanek wrote:
  > >  So, Bernd asked where the discussions were...
  > On ruby-talk, like this one:
  > Discussions like this crop up every few weeks or so.
  > It's like you installed perl 6, named it perl 5.12, and expected it to
  > run perl 5 code.
  > If you want to do that I'm not stopping you, I can always change the
  > makefile to install the version I want. It's just an additional
  > annoyance.
 So... it's two and a half years later; has the Ruby community come to
 terms with this? If there are still serious compatibility issues, it
 seems to make sense to me to provide a previous-version package, or
 even more than one like we do for certain other interpreters. But if
 the Ruby world has moved on, perhaps we can close this PR...
 David A. Holland

Home | Main Index | Thread Index | Old Index