pkgsrc-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: pkg/44597 (add native Kerberos support on Solaris)

The following reply was made to PR pkg/44597; it has been noted by GNATS.

From: =?ISO-8859-1?Q?J=F6rn_Clausen?= <>
Cc: OBATA Akio <>,,,
Subject: Re: pkg/44597 (add native Kerberos support on Solaris)
Date: Wed, 01 Jun 2011 13:29:10 +0200

 >   If only security/mit-rkb5-appl require mit-krb5>=1.8.0,
 >   how about just put>=1.8.0 on
 >   security/mit-krb-appl/Makefile?
 Isn't this how BUILDLINK_*_DEPENDS should work in the first place? The 
 consumer defines, which version is necessary, not the provider?
 I just tweaked security/mit-krb5/ to be happy with 1.4.0, 
 and security/p5-GSSAPI compiles (though I haven't tested it yet).
 In addition I had to do this change in security/mit-krb5
 ---  2011/04/27 09:08:46     1.1
 +++  2011/05/31 07:22:30
 @@ -39,7 +39,7 @@
   .  if empty(SH_KRB5_CONFIG:M__nonexistent__)!=     ${SH_KRB5_CONFIG} --version | \
 -                               ${SED} -e 's/.*release //' -e 's/-.*//'
 +                               ${SED} -e 's/.*release \([0-9\.]*\).*/\1/'
   .  endif     1.4.0          mit-krb5-${}
 as /usr/bin/krb5-config --version returns
 Solaris Kerberos (based on MIT Kerberos 5 release 1.4.0)
 and the original regex kept the closing parenthesis. I don't know if 
 there are versions of Kerberos that have other characters in the version 
 string, so this might not be portable.
   Jörn Clausen                    
   Universität Bielefeld

Home | Main Index | Thread Index | Old Index