pkgsrc-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

pkg/44779: build failure of multimedia/gst-plugins0.10-vp8 on NetBSD current (i386)

>Number:         44779
>Category:       pkg
>Synopsis:       build failure of multimedia/gst-plugins0.10-vp8 on NetBSD 
>current (i386)
>Confidential:   no
>Severity:       serious
>Priority:       medium
>Responsible:    pkg-manager
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Mon Mar 28 09:55:00 +0000 2011
>Originator:     Ryo ONODERA
>Release:        NetBSD 5.99.48
System: NetBSD 5.99.48 NetBSD 5.99.48 (LEAFGIRL3) 
#0: Sun Mar 27 19:33:19 JST 2011
Architecture: i386
Machine: i386
On NetBSD/i386 current machine, gst-plugins0.10-vp8-0.10.21 fails to build.
As far as I know, on NetBSD/i396 5.1, I can build it.

configure: *** Orc acceleration enabled.

=> Modifying libtool scripts to use pkgsrc libtool
WARNING: *** Please consider adding c++ to USE_LANGUAGES in the package 
===> Building for gst-plugins0.10-vp8-0.10.21
  CC     libgstvp8_la-gstvp8dec.lo
  CC     libgstvp8_la-gstvp8enc.lo
gstvp8enc.c: In function 'gst_vp8_enc_handle_frame':
gstvp8enc.c:766: warning: dereferencing type-punned pointer will break 
strict-aliasing rules
  CC     libgstvp8_la-gstvp8utils.lo
  CC     libgstvp8_la-plugin.lo
libtool: link: warning: library 
`/usr/tmp/multimedia/gst-plugins0.10-vp8/work/.buildlink/lib/' was 
==> [buildlink3] Error: buildlink3 leakage into ./.libs/libgstvp8.lai
gmake: *** [] Error 1
*** Error code 2

make: stopped in /usr/pkgsrc/multimedia/gst-plugins0.10-vp8
*** Error code 1

make: stopped in /usr/pkgsrc/multimedia/gst-plugins0.10-vp8
On NetBSD/i386 current,
$ cd /usr/pkgsrc/multimedia/gst-plugins0.10-vp8
$ make
I have no idea.


Home | Main Index | Thread Index | Old Index