pkgsrc-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

pkg/44103: x11/vte fails in phase configure with error "-Bsymbolic requested but not supported by ld"

>Number:         44103
>Category:       pkg
>Synopsis:       x11/vte fails in phase configure with error  "-Bsymbolic 
>requested but not supported by ld"
>Confidential:   no
>Severity:       serious
>Priority:       medium
>Responsible:    pkg-manager
>State:          open
>Class:          support
>Submitter-Id:   net
>Arrival-Date:   Wed Nov 17 10:00:00 +0000 2010
>Originator:     Volkmar Seifert
>Release:        NetBSD/sparc64 5.1_RC4
NetBSD 5.1_RC4 NetBSD 5.1_RC4 (GENERIC.MP) #0: Tue 
Oct 19 11:36:21 CEST 2010

x11/vte is installed as one of many dependencies to the meta-package xfce4, 
which I actually attempted to install.

In the configure-phase, x11/vte fails with the error

checking whether cc supports -Wl,-Bsymbolic-functions when linking... 
configure: error: -Bsymbolic requested but not supported by ld

Which is slightly misleading, as /usr/bin/ld (the only ld on my system) does 
actually support -Bsymbolic. A look into .work.log revealed that the real 
parameter is (as stated above, too), -Bsymbolic-functions is used, which isn't 
known to ld.

In reference to certain other PRs: the system has just been set up,  
cd x11/vte
make install

no specific options or anything necessary
Unkown, my assumption is to patch the configure-script not to use 
-Bsymbolic-functions but -Bsymbolic .
But I cannot do that, as I am not very familiar with all that configure-magic.

Home | Main Index | Thread Index | Old Index