pkgsrc-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: pkg/42746 (devel/boost-libs needs an extra flag with gcc-4.4)

The following reply was made to PR pkg/42746; it has been noted by GNATS.

From: Tim Zingelman <>
To: Steven Drake <>
Subject: Re: pkg/42746 (devel/boost-libs needs an extra flag with gcc-4.4)
Date: Wed, 6 Oct 2010 18:37:11 -0500

 So, it looks like the real fix might be to adjust
 pkgsrc/mk/compiler/ to add something like these lines:
  .if !empty(USE_LANGUAGES:Mc++0x)
  GCC_REQD+=  4.4
  _WRAP_EXTRA_ARGS.CXX+=   -std=c++0x
 and then add to the pkgsrc/devel/boost-libs/Makefile this line:
  USE_LANGUAGES+=  c++0x
 Trouble is this then requires at least gcc 4.4 to build boost-libs,
 while in reality they build fine with 3.4.6... a bit of chicken and
 egg, since we'd like to check CC_VERSION to see which compiler version
 we have and then if we have gcc-4.4+ add the USE_LANGUAGES+=  c++0x...
 but it is not clear if there is a clean way to do that since
 mk/ sets CC_VERSION and so it can't also later act on
 A short term work around is to simply add:
  .if !empty(CC_VERSION:Mgcc-4.4.*)
  _WRAP_EXTRA_ARGS.CXX+=   -std=c++0x
 to the pkgsrc/devel/boost-libs/Makefile but I think this should not be
 added to the cvs repo because the _WRAP_EXTRA_ARGS.CXX is likely
 intended to be internal to pkgsrc/mk/...
 Can anyone else comment on this?
 (see also which may or may not be related)

Home | Main Index | Thread Index | Old Index