pkgsrc-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: pkg/43465 (devel/boost-libs PLIST incorrect)

The following reply was made to PR pkg/43465; it has been noted by GNATS.

From: Tim Zingelman <>
To: Hauke Fath <>
Subject: Re: pkg/43465 (devel/boost-libs PLIST incorrect)
Date: Tue, 5 Oct 2010 10:38:35 -0500

 On Mon, Oct 4, 2010 at 10:54 AM, Tim Zingelman <> 
 > On Sun, Oct 3, 2010 at 2:57 PM, Hauke Fath
 > <> wrote:
 >> At 15:32 Uhr -0500 23.9.2010, Tim Zingelman wrote:
 >>>Could you try building with the BUILDLINK_TRANSFORM line added to your
 >>>Makefile, and/or provide the errors encountered above the ...failed
 >> Hi Tim,
 >> thanks for looking at the PR.
 >> It took me a while to get the ss20 back to the point where it would atte=
 >> to build boost-libs (think: perl upgrade...).
 >> Short version of the build outcome: Ading
 >> BUILDLINK_TRANSFORM+=3D =A0 rm:-fvisibility=3Dhidden
 >> to the package Makefile does not make any difference. I get the exact sa=
 >> files listed as on the PLIST, but missing from the file system.
 > Could you check what the few lines above:
 > "...failed gcc.compile.c++.pch
 > bin.v2/libs/math/build/gcc-3.4.6/release/link-static/threading-multi/../s=
 > in the build output are?
 I also just noticed which may be the
 same problem you are seeing... and now that I've finally convinced gcc
 4.x to build on solaris, I am seeing that problem too (and not the
 visibility issue that only shows up in gcc 3.x)  I'm looking at how to
 best work around this '-std=3Dc++0x required' problem now.
  - Tim

Home | Main Index | Thread Index | Old Index