pkgsrc-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

pkg/43916: p5-Net-SSLeay build failure on Solaris 10

>Number:         43916
>Category:       pkg
>Synopsis:       p5-Net-SSLeay build failure on Solaris 10
>Confidential:   no
>Severity:       serious
>Priority:       medium
>Responsible:    pkg-manager
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Mon Sep 27 15:10:06 +0000 2010
>Originator:     Jim Wise
>Release:        Solaris 10
Build of security/p5-Net-SSLeay on Solaris 10, pretty much empty mk.conf fails 

gondolin$ bmake
=> Bootstrap dependency digest>=20010302: found digest-20080510
=> Bootstrap dependency tnftp-[0-9]*: found tnftp-20070806
===> Checking for vulnerabilities in p5-Net-SSLeay-1.36nb1
=> Checksum SHA1 OK for Net-SSLeay-1.36.tar.gz
=> Checksum RMD160 OK for Net-SSLeay-1.36.tar.gz
===> Installing dependencies for p5-Net-SSLeay-1.36nb1
The following variables will affect the build process of this package,
p5-Net-SSLeay-1.36nb1.  Their current value is shown below:

        * SSLBASE (defined)
        * SSLCERTS = /etc/opt/tnf/openssl/certs
        * SSLDIR = /etc/opt/tnf/openssl
        * SSLKEYS = /etc/opt/tnf/openssl/private

You may want to abort the process now with CTRL-C and change their value
before continuing.  Be sure to run `/opt/tnf/bin/bmake clean' after
the changes.
=> Build dependency p5-Test-Exception-[0-9]*: found p5-Test-Exception-0.29nb2
=> Build dependency p5-Test-Warn-[0-9]*: found p5-Test-Warn-0.22
=> Build dependency pax>=20040802: found pax-20080110
=> Full dependency {perl>=5.7.3,p5-MIME-Base64-[0-9]*}: found perl-5.12.2
=> Full dependency perl<5.14.0: found perl-5.12.2
=> Full dependency perl>=5.12.0: found perl-5.12.2
=> Full dependency openssl>=0.9.8knb1: found openssl-0.9.8o
===> Overriding tools for p5-Net-SSLeay-1.36nb1
===> Extracting for p5-Net-SSLeay-1.36nb1
===> Patching for p5-Net-SSLeay-1.36nb1
===> Creating toolchain wrappers for p5-Net-SSLeay-1.36nb1
===> Configuring for p5-Net-SSLeay-1.36nb1
Cannot determine perl version info from lib/Net/
Cannot determine license info from lib/Net/
*** OpenSSL version test failed
    (`' has been returned)
    Either you have bogus OpenSSL or a new version has changed the version
    number format. Please inform the authors!
*** Error code 255

bmake: stopped in /opt/tnf/pkgsrc/security/p5-Net-SSLeay
*** Error code 1

bmake: stopped in /opt/tnf/pkgsrc/security/p5-Net-SSLeay
        cd /opt/tnf/pkgsrc/security/p5-Net-SSLeay && bmake

Home | Main Index | Thread Index | Old Index