pkgsrc-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: pkg/43518 (converters/libiconv fails to build on OpenSolaris)

The following reply was made to PR pkg/43518; it has been noted by GNATS.

From: Tim Zingelman <>
Subject: Re: pkg/43518 (converters/libiconv fails to build on OpenSolaris)
Date: Sun, 12 Sep 2010 18:50:04 -0500

 Sorry I'm just getting back to look at this...
 I don't see this problem on Solaris sparc, but I admit I'm not clear
 on why... the problem is the part of the line "-Wl,-soname
 -Wl," which seems to be gnu ld specific, and should be
 "-Wl,-h -Wl," for solaris ld.  Somehow when I build,
 that is what I get... it does not appear to be the pkgsrc wrappers
 doing the fix, as they only make that fix when also using the sun
 compiler... and I use gcc.  The libiconv configure script is
 apparently failing to figure this out for you, but is figuring it out
 for me.  Gcc will use sun ld even when gnu ld is in your path first,
 if it was built to do so... maybe make sure gnu ld is not anyplace in
 your path? (or at least after sun ld?)
  - Tim

Home | Main Index | Thread Index | Old Index