pkgsrc-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

pkg/43868: Building X11 packages broken on platforms that use bundled X11

>Number:         43868
>Category:       pkg
>Synopsis:       Building X11 packages broken on platforms that use bundled X11
>Confidential:   no
>Severity:       serious
>Priority:       high
>Responsible:    pkg-manager
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Sat Sep 11 18:25:00 +0000 2010
>Originator:     Matthias Scheler
>Release:        NetBSD 5.1_RC3 pkgsrc HEAD from 2010-09-11
Matthias Scheler                        
System: NetBSD 5.1_RC3 NetBSD 5.1_RC3 (COLWYN.64) #2: Sat 
Jul 17 15:04:37 BST 2010 amd64
Architecture: x86_64
Machine: amd64
Building X11 packages (e.g. "devel/pango") is broken on platforms which
don't use X11 from "pkgsrc":

=> Bootstrap dependency digest>=20010302: found digest-20080510
===> Checking for vulnerabilities in pango-1.28.1nb1
=> Checksum SHA1 OK for pango-1.28.1.tar.bz2
=> Checksum RMD160 OK for pango-1.28.1.tar.bz2
===> Installing dependencies for pango-1.28.1nb1
The supported build options for pango are:

        libthai x11

The currently selected options are:


You can select which build options to use by setting PKG_DEFAULT_OPTIONS
or the following variable.  Its current value is shown:

        PKG_OPTIONS.pango (not defined)

=> Build dependency help2man-[0-9]*: found help2man-1.38.2nb1
=> Build dependency libtool-base>=2.2.6bnb3: found libtool-base-2.2.6bnb4
=> Build dependency gmake>=3.81: found gmake-3.82nb1
=> Build dependency pkg-config>=0.19: found pkg-config-0.23nb1
=> Build dependency x11-links>=0.50: found x11-links-0.50
=> Build dependency xcb-proto>=1.4: found xcb-proto-1.6
=> Build dependency checkperms>=1.1: found checkperms-1.11
=> Full dependency glib2>=2.17.3: found glib2-2.24.2
=> Full dependency cairo>=1.8.10nb1: found cairo-1.8.10nb1
===> Overriding tools for pango-1.28.1nb1
===> Extracting for pango-1.28.1nb1
===> Patching for pango-1.28.1nb1
=> Applying pkgsrc patches for pango-1.28.1nb1
===> Creating toolchain wrappers for pango-1.28.1nb1
ERROR: libxcb>=1.1.93 is not installed; can't buildlink files.
*** Error code 1

make: stopped in /src/NetBSD-current/pkgsrc/devel/pango
*** Error code 1

make: stopped in /usr/pkgsrc/devel/pango

This happens under NetBSD 5.1 and Mac OS 10.6.4 and probably a lot of
other platforms.

cd pkgsrc/devel/pango

Not known.

Home | Main Index | Thread Index | Old Index