pkgsrc-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

pkg/43585: Recent print/cups pkg doesn't work with net/mDNSResponder-108

>Number:         43585
>Category:       pkg
>Synopsis:       Recent print/cups pkg doesn't work with net/mDNSResponder-108
>Confidential:   no
>Severity:       serious
>Priority:       medium
>Responsible:    pkg-manager
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Thu Jul 08 19:25:00 +0000 2010
>Originator:     Steve Woodford
>Release:        NetBSD 5.1_RC3
System: NetBSD 5.1_RC3 NetBSD 5.1_RC3 (GENERIC) #0: Sun Jul 4 
10:43:06 BST 2010 amd64
Architecture: x86_64
Machine: amd64
CUPS now requires a newer version of mDNSResponder than the ancient version
currently in pkgsrc. As a result, the CUPS configure script will disable
Bonjour support at build time making it rather tricky to share printers to
MacOS boxen.
Build pkgsrc/print/cups. Note the following in config.log:

configure:9920: checking for current version of dns_sd library
configure:9939: cc -c -I/usr/include/krb5  -O2 -I/usr/pkg/include 
-I/usr/X11R7/include -I/usr/include/kr
b5 -I/usr/include -I/usr/pkg/include/dbus-1.0 -I/usr/pkg/lib/dbus-1.0/include   
ANGE -I/usr/include/krb5  -I/usr/pkg/include -I/usr/X11R7/include 
-I/usr/include/krb5 -I/usr/include con
ftest.c >&5
conftest.c: In function 'main':
conftest.c:102: error: 'kDNSServiceFlagsShareConnection' undeclared (first use 
in this function)
conftest.c:102: error: (Each undeclared identifier is reported only once
conftest.c:102: error: for each function it appears in.)

Update pkgsrc/net/mDNSResponder to at least version 164.

Home | Main Index | Thread Index | Old Index