pkgsrc-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: pkg/43567 (Please update emulators/aranym to 0.9.10)


From: "OBATA Akio" <>
Subject: Re: pkg/43567 (Please update emulators/aranym to 0.9.10)
Date: Wed,  7 Jul 2010 12:55:01 +0000 (UTC)

> The following reply was made to PR pkg/43567; it has been noted by GNATS.
> From: "OBATA Akio" <>
> To:
> Cc: 
> Subject: Re: pkg/43567 (Please update emulators/aranym to 0.9.10)
> Date: Wed, 07 Jul 2010 21:50:09 +0900
>  Two fixes:
>  * EMUTOS_DOC_DIR and EMUTOS_ROM_DIR must not prefixed with DESTDIR,
>     or it result in REQD_DIRS contains DESTDIR.
>  * update of patch-ac is probably bad, previously patch to "install" target,
>     but your update patch to "bindist" target.

Thank you for your fix.
Second issue is my mistake.

On First, I did not see EMUTOS_DOC_DIR and EMUTOS_ROM_DIR.

>  Two questions:
>  * Why --enable-atc=full and --enable-lilo are added to CONFIGURE_ARGS?
>     Probably, former is OK, because it is default=yes in configure script.
>     but later is default=no and need extra dependency on zlib.

Adding --enable-lilo is my mistake.
Probably when I was working 0.9.9 (not 0.9.10), I had enabled this option.
And I forget to delete it.
Please delete it.

>  * Why --enable-jit-compiler and --enable-jit-fpu only on Linux-*-i386?

On aranym 0.9.9 (not 0.9.10), these option is not working on NetBSD.
And the documents said JIT is designed to use with Linux/i386.
But probably some patch enable JIT on NetBSD (sadly I cannot understand this 

Thank you.

PGP fingerprint = 82A2 DC91 76E0 A10A 8ABB  FD1B F404 27FA C7D1 15F3

Home | Main Index | Thread Index | Old Index