pkgsrc-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

pkg/43478: rpm2pkg 3.0.1 complains about cpio header errors...

>Number:         43478
>Category:       pkg
>Synopsis:       rpm2pkg 3.0.1 complains about cpio header errors
>Confidential:   no
>Severity:       serious
>Priority:       medium
>Responsible:    pkg-manager
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Tue Jun 15 15:05:00 +0000 2010
>Originator:     Greg Oster
>Release:        NetBSD 5.1_RC3
System: NetBSD scrooge 5.1_RC3 NetBSD 5.1_RC3 (QUAD) #0: Sun Jun 13 16:32:20 
CST 2010 
Architecture: i386
Machine: i386

Attempt to install print/acroread8 on NetBSD 5.1_RC3 i386 with
up-to-date pkgsrc, and observe the following error: 

===> Installing dependencies for suse_compat-10.0nb3
The following variables will affect the build process of this package,
suse_compat-10.0nb3.  Their current value is shown below:

        * RPMFILES = 

You may want to abort the process now with CTRL-C and change their value
before continuing.  Be sure to run `/usr/bin/make clean' after
the changes.
=> Build dependency rpm2pkg>=2.1: found rpm2pkg-3.0.1
=> Full dependency suse_base-10.0{,nb*}: NOT found
=> Verifying reinstall for ../../emulators/suse100_base
=> Bootstrap dependency digest>=20010302: found digest-20080510
===> Skipping vulnerability checks.
WARNING: No /var/db/pkg/pkg-vulnerabilities file found.
WARNING: To fix run: `/usr/sbin/pkg_admin -K /var/db/pkg 
===> Installing for suse_base-10.0nb5
=> Creating installation directories
=> Running PRE-INSTALL script actions
=> Extracting RPM files
/usr/pkgsrc/distfiles/suse100/i586/aaa_base-10.0-28.i586.rpm: error in cpio 
*** Error code 1

make: stopped in /usr/pkgsrc/emulators/suse100_base
*** Error code 1

make: stopped in /usr/pkgsrc/emulators/suse100_base
*** Error code 1

make: stopped in /usr/pkgsrc/emulators/suse100_base
*** Error code 1

make: stopped in /usr/pkgsrc/emulators/suse100_compat
*** Error code 1

make: stopped in /usr/pkgsrc/print/acroread8

The problem is seen with versions 3.0 and 3.0.1 of rpm2pkg.  Version
2.3 doesn't have this issue.

        Attempt to build print/acroread8 from pkgsrc.  Observe the
claimed error cpio header.
        Downgrade to rpm2pkg version 2.3 to get around the issue.

Home | Main Index | Thread Index | Old Index