pkgsrc-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

pkg/43081: pkgsrc PHP specific version build machinery fails (NetBSD 4.0/i386)

>Number:         43081
>Category:       pkg
>Synopsis:       pkgsrc PHP specific version build machinery fails (NetBSD 
>Confidential:   no
>Severity:       serious
>Priority:       medium
>Responsible:    pkg-manager
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Tue Mar 30 10:40:00 +0000 2010
>Originator:     Robert Elz
>Release:        NetBSD 4.0 / i386   (pkgsrc current 2010-03-30)
        Prince of Songkla University
System: NetBSD 4.0_STABLE NetBSD 4.0_STABLE 
(JADE-1.696-20080517) #9: Fri May 23 18:55:13 ICT 2008 i386
Architecture: i386
Machine: i386
        www/gallery includes in its pkgsrc Makefile ...

                PHP_VERSIONS_ACCEPTED=  53

        and then


        That combination is clearly intended to get php53-gd-*
        installed (some version newer than 4.1.0 - the version is not
        the issue).

        And what's more, that's what it attempts to do ...

                => Full dependency php53-gd>=4.1.0: NOT found
                => Verifying bin-install for ../../graphics/php-gd
                ===> Binary install for php53-gd>=4.1.0

        which fails, as there's no binary package for that built
        on my system so it reverts to building from source ...

                => Installing php53-gd>=4.1.0 from /pkg_comp/packages/All
                pkg_add: no pkg found for 'php53-gd>=4.1.0', sorry.
                pkg_add: 1 package addition failed
                => No binary package found for php53-gd>=4.1.0; installing from 

        So far, so good, that's all what is supposed to happen,
        except ...

                => Bootstrap dependency digest>=20010302: found digest-20080510
                WARNING: [] Every package should define a LICENSE.
                => Checksum SHA1 OK for php-5.2.13/php-5.2.13.tar.bz2
                => Checksum RMD160 OK for php-5.2.13/php-5.2.13.tar.bz2

        Hmmm... php 5.2, what's up there?

        And sure enough, after a perfectly successful build ...

                => Registering installation for php5-gd-5.2.13 
                php5-gd-5.2.13 requires installed package freetype2-2.3.12
                php5-gd-5.2.13 requires installed package jpeg-8nb1
                php5-gd-5.2.13 requires installed package php-5.2.13nb1  
                php5-gd-5.2.13 requires installed package png-1.2.43
                => Checking file-check results for php5-gd-5.2.13
                => Checking for non-existent script interpreters in 
                => Checking file permissions in php5-gd-5.2.13
                => Checking for missing run-time search paths in php5-gd-5.2.13 
                => Checking for work-directory references in php5-gd-5.2.13
                ===> Building binary package for php5-gd-5.2.13
                => Creating binary package 
                ERROR: [] A package matching ``php53-gd>=4.1.0'' 
                ERROR:     be installed, but one cannot be found.  Perhaps 
there is a
                ERROR:     stale work directory for ../../graphics/php-gd?
                *** Error code 1

                make: stopped in /usr/pkgsrc/www/gallery
                *** Error code 1 


        I use pkg_comp with NetBSD 4.0 release sets installed (I doubt
        any of that matters here) - I use libkver to simulate NetBSD 4.0
        for uname, and X11_TYPE=modular instead of the x* sets

        Again, I dount any of that really matters - except that when
        the build starts, there is nothing related to PHP installed
        (the pkg_comp sandbox is essentially empty) and there is
        nothing related to PHP or PHP versions in mk.conf (everything
        is just whatever comes in pkgsrc by default).

        In that environment, (and with no binary package for php53-gd
        available - if there was one it would probably have been
        installed and all would have been OK) attempt to build
        www/gallery (or www/gallery2 - it exhibits the same problem).

        If I were to install php53, or set the default PHP version,
        or just had a binary package for the dependency available,
        this problem would probably have remained hidden.

        ??   Somehow the desired version of PHP needs to be passed
        through the build machinery to PHP packages, when a package
        needs a specific version  - simply going to the php package
        directory and saying "build" isn't going to do it, that will
        just vuild the default version, not the version that is needed.

Home | Main Index | Thread Index | Old Index