pkgsrc-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: pkg/42971: x11/libxcb sports undeclared dependency on "xau"

On Sun, Mar 14, 2010 at 06:20:05PM +0000, Joerg Sonnenberger wrote:
 >>>  Even if it is modified to create fake pkgconfig files correctly, the
 >>>  XFree86 in NetBSD 4 is way too old.
 >>  Right, well, shouldn't it reject the builtin version then, like other
 >>  builtin logic does?
 >  That's not really going to help if it means mixing different shared
 >  library versions. Ultimately it just means someone has to care enough
 >  about ancient/native X11 to do the work and I am not the person to do
 >  that.

I know X is a mess, but I don't see that it's really different from
needing a new-enough version of any other package... if the pkgsrc
libXau needs a newer libX11 than the builtin one it should go ahead
and build the libX11 from pkgsrc and nothing should get mixed. It's
possible that we might want X11_TYPE==native to explicitly fail this;
but then you'd get a sane error message out.

David A. Holland

Home | Main Index | Thread Index | Old Index