pkgsrc-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: pkg/42922 (netpgp needs feature test macros to compile under glibc.)

On Fri, 5 Mar 2010, wrote:
> i personally don't like the definitions that we're being forced to add for
> newer glibc on linux

What I found surprising is that there is no autoconf macro designed to
workout what c macros if any are needed and to define them in config.h
e.g. "AC_GLIBC(strdup) ..."

> thanks for the problem report - please can you report back that these
> changes fix things for you on newer linux - previous testing on linux
> has been done with various versions of rhel, so i've been immune to this.

I tested netpgp-20100212 and it complied without any problems.


Home | Main Index | Thread Index | Old Index