pkgsrc-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

pkg/42822: pkgsrc should set a default for packages that require PKG_DEFAULT_OPTIONS=inet6

>Number:         42822
>Category:       pkg
>Synopsis:       pkgsrc should set a default for packages that require 
>Confidential:   no
>Severity:       non-critical
>Priority:       low
>Responsible:    pkg-manager
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Tue Feb 16 02:50:00 +0000 2010
>Originator:     Jan Schaumann
>Release:        NetBSD 5.0

        After bootstrapping pkgsrc on various linux and solaris systems and 
trying to
        build net/sipcalc, I get the following error:

ERROR: This package has set PKG_FAIL_REASON:
ERROR: [] One of the following options must be selected: inet6
*** Error code 1

        It's very cumbersome for the end-user to have to make such decisions.
        Each options that must be set should have a reasonable default, possibly
        determined at bootstrap time.  The package can still display a warning
        (as I think it would) if the option is set to indicate what it is and
        what it could be, but bailing out on a default installation saying
        "I don't know what to do" is not very user friendly at all.

        cd /usr/pkgsrc/bootstrap
        cd ../net/sipcalc


Home | Main Index | Thread Index | Old Index