pkgsrc-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

pkg/42819: databases/ruby-activeldap distfile checksum error

>Number:         42819
>Category:       pkg
>Synopsis:       databases/ruby-activeldap distfile checksum error
>Confidential:   no
>Severity:       non-critical
>Priority:       medium
>Responsible:    pkg-manager
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Mon Feb 15 14:00:00 +0000 2010
>Originator:     Robert Elz
>Release:        pkgsrc current as of 2010-02-15
        Prince of Songkla University
System: NetBSD 5.0.2 NetBSD 5.0.2 (JADE-$Revision: 1.12 $) 
#17: Fri Feb 12 18:27:01 ICT 2010 i386
Architecture: i386
Machine: i386
        The distfile (gem) available from the master site for
        databases/ruby-activeldap (version 1.2.1 - the newly updated one)
        doesn't match the checksum in the distinfo file.

        mv ..../distfiles/activeldap-1.2.1.gem /somewhere/safe
        cd ..../pkgsrc/databases/ruby-activeldap
        make checksum

        Find out what changed between the distfile used to make the
        package, and the one currently available.   If everything
        looks OK, just update the distinfo file.   No need to bother
        with a DIST_SUBDIR in this case - it appears as if there
        have been two versions of 1.2.1, one Dec 15 (2009), the other
        Dec 16 (2009).   Only the latter is available now, but I'd
        guess that this package was made from the former.   Given the
        short window when the old distfile was available, and that it
        was (almost) 2 months before pkgsrc started requesting this
        distfile, the chances that anyone (except perhaps one) has the
        version matching the distinfo file are close enough to zero to ignore.

Home | Main Index | Thread Index | Old Index