pkgsrc-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

pkg/42749: PHP / Suhosin not in sync in pkgsrc

>Number:         42749
>Category:       pkg
>Synopsis:       PHP / Suhosin not in sync in pkgsrc
>Confidential:   no
>Severity:       serious
>Priority:       high
>Responsible:    pkg-manager
>State:          open
>Class:          change-request
>Submitter-Id:   net
>Arrival-Date:   Fri Feb 05 11:40:00 +0000 2010
>Originator:     Volkmar Seifert
>Release:        NetBSD 5
NetBSD heimdall 5.0.0_PATCH NetBSD 5.0.0_PATCH (HEIMDALL-1.0) #0: Thu Jul  2 
10:21:29 CEST 2009  
PHP is available in two stable versions: 5.2.12 and 5.3.1.
Suhosin is available for BOTH versions, though make in lang/php5 claims this 
not to be the case.
Suhosin version 0.9.7 offers the support for 5.2.12, while Suhosin version 
0.9.8 offers support for 5.3.x.

This is what make says:

ERROR: This package has set PKG_FAIL_REASON:
ERROR: The suhosin patch is currently not available for
ERROR: this version of PHP.  You may have to wait until
ERROR: an updated patch is released or temporarily
ERROR: build this package without the suhosin option.

(Please note that this error is totally system-independend!)

cd lang/php

(Please note that this is totally system-independend!)
Allow Suhosin version 0.9.7 to be used, or switch to PHP 5.3.1, to be able to 
use Suhosin version 0.9.8.

Home | Main Index | Thread Index | Old Index