pkgsrc-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

pkg/42705: time/gtodo-applet build causes make to dump core on NetBSD 4.0 (i386) (+FIX)

>Number:         42705
>Category:       pkg
>Synopsis:       time/gtodo-applet build causes make to dump core on NetBSD 4.0 
>(i386) (+FIX)
>Confidential:   no
>Severity:       serious
>Priority:       medium
>Responsible:    pkg-manager
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Sat Jan 30 11:35:00 +0000 2010
>Originator:     Robert Elz
>Release:        NetBSD 4.0 / i386   (pkgsrc -current 2010-01-30)
        Prince of Songkla University
System: NetBSD 4.0_STABLE NetBSD 4.0_STABLE 
(JADE-1.696-20080517) #9: Fri May 23 18:55:13 ICT 2008 i386
Architecture: i386
Machine: i386
        NetBSD 4.0's make command contains a bug dealing with long
        input lines - this is long fixed in more recent versions of
        NetBSD, but is not fixed in any released version of NetBSD 4
        (which is still supposed to be supported by pkgsrc).

        time/gtodo-applet triggers that bug - and so needs to use
        a different version of make to build

        I use pkg_comp with NetBSD 4.0 release sets installed
        (the use of NetBSD 4.0 (or 4.0.1) is critical to experience
        this problem, you won't see it on NetBSD 5 or later - even
        someone running NetBSD 4_STABLE from CVS probably won't see it).

        I have libkver to simulate a NetBSD 4.0 environment fully
        (but that's not important for this issue) - and I use
        pkgsrc modular xorg (X11_TYPE=modular) rather than installing
        the x* sets (totally irrelevant to this problem).

        With that environment, attempting to build time/gtodo-applet
        results in ...

===> Installing for gtodo-applet-0.1nb18
=> Generating pre-install file lists
Making install in src
[1]   Segmentation fault (core dumped) (cd ${subdir} &&...
*** Error code 1

make: stopped in /pkg_comp/obj/pkgsrc/time/gtodo-applet/4x/gtodo-applet-0.1

        The core dump is from make.

        Assuming the change requested in PR pkg/42704 has been applied,
        the following patch "fixes" time/gtodo-applet, so that it builds

        A better fix would probably add the USE_TOOLS+= bmake line only
        for NetBSD 4.0 (it would be harmless everywhere, I believe, but does
        add additional overhead - though if you're installing gnome related
        stuff, you'd be used to LOTS of overhead already!)

        If the update in pkg/42704 is not accepted, changing "bmake" to
        "gmake" in the patch will probably work, but I have not verified
        that (it has worked previously - for other packages with the same

Index: Makefile
RCS file: /cvsroot/NetBSD/pkgsrc/time/gtodo-applet/Makefile,v
retrieving revision 1.28
diff -u -r1.28 Makefile
--- Makefile    18 Jan 2010 09:59:28 -0000      1.28
+++ Makefile    30 Jan 2010 10:52:23 -0000
@@ -15,6 +15,7 @@
 DEPENDS+=              gtodo>=0.14:../../time/gtodo
 USE_TOOLS+=            pkg-config
+USE_TOOLS+=            bmake
 USE_LIBTOOL=           YES

Home | Main Index | Thread Index | Old Index