pkgsrc-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

pkg/42647: mutt-devel with sasl doesn't pull in any authenticators

>Number:         42647
>Category:       pkg
>Synopsis:       mutt-devel with sasl doesn't pull in any authenticators
>Confidential:   no
>Severity:       non-critical
>Priority:       low
>Responsible:    pkg-manager
>State:          open
>Class:          change-request
>Submitter-Id:   net
>Arrival-Date:   Wed Jan 20 05:00:00 +0000 2010
>Originator:     Christopher Berardi
>Release:        NetBSD 5.0.1
NetBSD 5.0.1 NetBSD 5.0.1 (GENERIC) #0: Thu Jul 30 
01:39:11 UTC 2009
Running NetBSD 5.0.1 with pkgsrc-2009Q4. When you install mutt-devel with the 
sasl option, it installs the prerequisite cyrus-sasl, but it doesn't also bring 
any authenticators. This makes mutt's utilization of sasl pretty useless until 
you manually also install some. 

I would recommend either automatically installing say 2-3 of the most common 
authenticators (such as PLAIN) automatically when including sasl with 
mutt-devel, or branching the options so a particular one can be choosen, such 
as (PKG_OPTIONS.mutt+=sasl-plain sasl-login).

Home | Main Index | Thread Index | Old Index