pkgsrc-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: pkg/42511: graphics/kdegraphics3 PLIST problems (NetBSD 4.0 / i386)

The following reply was made to PR pkg/42511; it has been noted by GNATS.

From: Robert Elz <kre%munnari.OZ.AU@localhost>
Subject: Re: pkg/42511: graphics/kdegraphics3 PLIST problems (NetBSD 4.0 / i386)
Date: Wed, 30 Dec 2009 12:21:52 +0700

     Date:        Tue, 29 Dec 2009 19:20:03 +0000 (UTC)
     From:        Mark Davies <>
     Message-ID:  <>
   |  Not building/installing kamera implies that the configure didn't 
   |  successfully find gphoto2 but the dependency is there.  Could you send me 
   |  the output of configure.
 Thanks for the pointer - it was a libgphoto2 problem, but one I should have
 detected and corrected without sending a PR, please close this one, the
 problem I had isn't one that's likely to bother anyone else.
 For nyone who cares, what happened was that when libtool was broken, I
 reverted it (privalely), so I could continue building other packages that
 need a working libtool ... but that then meant that the packages that
 were revbumped because of the libltdl change were rebuilt with the old
 libltdl, then once libtool was fixed, the revbump was (for me) effectively
 lost ... so I had a libgphoto2 that was demanding the older .so from
 libltdl, and so linking failed when the libltdl package installed what
 was for libgphoto2 useless...   Kdegraphics' config then assumed that
 libgphoto2 wasn't installed, and ....
 All is corrected now. please close this PR, and apologies for wasting time.

Home | Main Index | Thread Index | Old Index