pkgsrc-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

pkg/42458: lang/kaffe PLIST problem (NetBSD 4.0/i386 w pkgsrc modular xorg)

>Number:         42458
>Category:       pkg
>Synopsis:       lang/kaffe PLIST problem (NetBSD 4.0/i386 w pkgsrc modular 
>Confidential:   no
>Severity:       serious
>Priority:       medium
>Responsible:    pkg-manager
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Tue Dec 15 13:25:00 +0000 2009
>Originator:     Robert Elz
>Release:        NetBSD 4.0 / i386 (pkgsrc current 2009-12-15)
        Prince of Songkla University
System: NetBSD 4.0_STABLE NetBSD 4.0_STABLE 
(JADE-1.696-20080517) #9: Fri May 23 18:55:13 ICT 2008 i386
Architecture: i386
Machine: i386
        Yesterday's update of lang/kaffe from 1.1.7nb3 to 1.1.7nb4
        says in its cvs log ...

                Override LIBLTDL explicitly to unbreak build with libtool 2.2.
                Fix PLIST. Bump revision.

        The LIBTOOL change seems OK, the revbump was obviously needed,
        but the "Fix PLIST" for me shoud be read as "Break PLIST".

        That is, in 1.1.7nb3, the PLIST was fine (correctly indicated what
        was installed, as tested by pkgsrc's file-check test), one entry
        was added, that file isn't installed (and it is a little hard to
        see how changing LIBTOOL usage could alter the need, or otherwise,
        for a .jar file to be installed).

        I use pkg_comp with libkver starting in a nearly empty sandbox,
        with NetBSD 4.0 release sets (except the x* sets) installed,
        and use pkgsrc modular xorg (X11_TYPE=modular) for x,
        Most likely none of that is rleevant here, but who knows...

        After building and installing lang/kaffe, but before a binary
        package is built, pkgsrc (with PKG_DEVELOPER=yes, which pkg_comp
        causes) runs its file-check tests, which results in ...

=> Checking file-check results for kaffe-1.1.7nb4
ERROR: ************************************************************
ERROR: The following files are in the PLIST but not in /usr/pkg:
ERROR:         /usr/pkg/java/kaffe/jre/lib/rt.jar 
*** Error code 1 

        .../rt.jar was added to the PLIST yesterday (part of the nb4 upgrade).

        Remove it from the PLIST again...

        In the build log I see this:

if test -f /usr/pkg/java/kaffe/jre/lib/ ; then \
                if ! test -f /usr/pkg/java/kaffe/jre/lib/rt.jar ; then \
                        ln -s /usr/pkg/java/kaffe/jre/lib/ 
/usr/pkg/java/kaffe/jre/lib/rt.jar ; \
                fi ; \

        That's obviously where rt.jar is supposed to come from,
        and if I run those commands manually, it gets created
        (that is, /usr/pkg/java/kaffe/jre/lib/ does exist,
        and /usr/pkg/java/kaffe/jre/lib/rt.jar did not).

        I have no idea why that didn't happen during the build,
        the commands are logged from make as if they were to be
        executed, but it seems that didn't happen - or perhaps
        something later removed the symlink again.  If that is
        what it was, I don't see what might have removed it.

        After doing that command (so rt.jar existed) I run "make update".
        (with no make clean or anything intervening).  When that finished,
        rt.jar was gone again.

Home | Main Index | Thread Index | Old Index