pkgsrc-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

pkg/42339: pkgsrc/x11/gtk2 must require more recent glib2.

>Number:         42339
>Category:       pkg
>Synopsis:       pkgsrc/x11/gtk2 must require more recent glib2.
>Confidential:   no
>Severity:       serious
>Priority:       medium
>Responsible:    pkg-manager
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Wed Nov 18 07:05:00 +0000 2009
>Originator:     enami tsugutomo
>Release:        NetBSD 5.0_STABLE
System: NetBSD 5.0_STABLE NetBSD 5.0_STABLE (GENERIC) #0: 
Wed Jul 29 19:18:16 JST 2009
Architecture: i386
Machine: i386
        Build of gtk2 fails if glib2 2.20.1 is installed on the system.
        Try to build pkgsrc/x11/gtk2 on the machine glib2 2.20.1 is
        installed and see the build fails as follows:

=> Bootstrap dependency digest>=20010302: found digest-20060826
=> Checksum SHA1 OK for gtk+-2.18.3.tar.bz2
=> Checksum RMD160 OK for gtk+-2.18.3.tar.bz2
===> Installing dependencies for gtk2+-2.18.3


checking whether make sets $(MAKE)... (cached) yes
checking pkg-config is at least version 0.9.0... yes
checking for BASE_DEPENDENCIES... configure: error: Package requirements 
(glib-2.0 >= 2.21.3    atk >= 1.13.0    pango >= 1.20    cairo >= 1.6) were not 

Requested 'glib-2.0 >= 2.21.3' but version of GLib is 2.20.1

        Require more recent version of glib2.

% cvs -q diff -u Makefile 
Index: Makefile
RCS file: /cvsroot/pkgsrc/x11/gtk2/Makefile,v
retrieving revision 1.189
diff -u -r1.189 Makefile
--- Makefile    21 Oct 2009 15:34:06 -0000      1.189
+++ Makefile    18 Nov 2009 06:30:20 -0000
@@ -94,7 +94,7 @@
 BUILDLINK_API_DEPENDS.atk+=    atk>=1.13.0
 .include "../../devel/atk/"
 .include "../../devel/gettext-lib/"
-BUILDLINK_API_DEPENDS.glib2+=  glib2>=2.19.7
+BUILDLINK_API_DEPENDS.glib2+=  glib2>=2.21.3
 .include "../../devel/glib2/"
 BUILDLINK_API_DEPENDS.pango+=  pango>=1.20.0
 .include "../../devel/pango/"

Home | Main Index | Thread Index | Old Index