pkgsrc-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

pkg/42275: libunique doesn't build with native XFree

>Number:         42275
>Category:       pkg
>Synopsis:       libunique doesn't build with native XFree
>Confidential:   no
>Severity:       non-critical
>Priority:       low
>Responsible:    pkg-manager
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Fri Nov 06 03:50:01 +0000 2009
>Originator:     Simon Burge
>Release:        NetBSD 4.0_STABLE with native XFree 4.5.0
Apparently none
System: NetBSD 4.0_STABLE NetBSD 4.0_STABLE 
(THOREAU-4) #7: Sun Sep 21 17:57:39 EST 2008
Architecture: i386
Machine: i386
        Native XFree86 on a netbsd-4 system doesn't install an x11.pc
        pkg-config file, and the libunique package seems to use this to
        determine if X11 is installed.

        Trying to build this package gives:

                checking for UNIQUE... configure: error: Package requirements 
                                           gtk+-2.0 >= 2.11.0) were not met:
                No package 'x11' found

        On a netbsd-4 system:

                cd /usr/pkgsrc/x11/libunique
                make configure

        None given.  A workaround is to install a dummy x11.pc into the
        work/.buildlink/lib/pkgconfig direcory after the first attempt
        to build the package fails.

        One suggestion is for pkgtools/x11-links to install an x11.pc for
        native X11?

Home | Main Index | Thread Index | Old Index