pkgsrc-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

pkg/42138: Cant build lang/gcc44

>Number:         42138
>Category:       pkg
>Synopsis:       Cant build lang/gcc44
>Confidential:   no
>Severity:       non-critical
>Priority:       medium
>Responsible:    pkg-manager
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Tue Sep 29 19:50:00 +0000 2009
>Originator:     Adam Hoka
NetBSD 5.99.18 NetBSD 5.99.18 (OHAI) #6: Wed Sep 23 
17:30:54 CEST 2009

When building gcc44 I get this:

/usr/pkgsrc/lang/gcc44/work/gcc-4.4.1/libiberty/alloca.c: In function 
/usr/pkgsrc/lang/gcc44/work/gcc-4.4.1/libiberty/alloca.c:200: warning: implicit 
declaration of function 'XNEWVEC'
/usr/pkgsrc/lang/gcc44/work/gcc-4.4.1/libiberty/alloca.c:200: error: expected 
expression before 'char'
/usr/pkgsrc/lang/gcc44/work/gcc-4.4.1/libiberty/alloca.c:200: warning: 
initialization makes pointer from integer without a cast
gmake[3]: *** [alloca.o] Error 1
gmake[3]: Leaving directory `/usr/pkgsrc/lang/gcc44/work/obj/libiberty'
gmake[2]: *** [all-stage2-libiberty] Error 2
gmake[2]: Leaving directory `/usr/pkgsrc/lang/gcc44/work/obj'
gmake[1]: *** [stage2-bubble] Error 2
gmake[1]: Leaving directory `/usr/pkgsrc/lang/gcc44/work/obj'
gmake: *** [all] Error 2
*** Error code 2

I have the same problem with the other version from wip too.
It used it build some time ago from wip, so I'm wondering if its
something I have installed?


Home | Main Index | Thread Index | Old Index