pkgsrc-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

pkg/42077: sysutils/devkitd compile errors (NetBSD 4.0 / i386)

>Number:         42077
>Category:       pkg
>Synopsis:       sysutils/devkitd compile errors (NetBSD 4.0 / i386)
>Confidential:   no
>Severity:       non-critical
>Priority:       low
>Responsible:    pkg-manager
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Thu Sep 17 14:10:01 +0000 2009
>Originator:     Robert Elz
>Release:        NetBSD 4.0 / i386   pkgsrc current 2009-09-17
        Prince of Songkla University
System: NetBSD 4.0_STABLE NetBSD 4.0_STABLE 
(JADE-1.696-20080517) #9: Fri May 23 18:55:13 ICT 2008 i386
Architecture: i386
Machine: i386
        sysutils/devkitd doesn't compile in a NetBSD 4.0 release
        environment.    I suspect it isn't intended to, but its
        Makefile does say...


        without any restrictions on netBSD versions.

        Attempt to build sysutils/devkitd on a NetBSD 4.0 (release)
        system.   I use pkg_comp with 4.0 release sets installed to
        obtain that environment (and libkver so uname, etc, work).
        (I don't use x*, but that's not relevant here).

        In that environment I see ...

gmake[1]: Entering directory 
cc -DHAVE_CONFIG_H -I. -DPACKAGE_LIBEXEC_DIR=\""/usr/pkg/libexec"\" 
-DPACKAGE_DATA_DIR=\""/usr/pkg/share"\" -DPACKAGE_BIN_DIR=\""/usr/pkg/bin"\" 
-DG_LOG_DOMAIN=\"devkit-daemon\"  -I/usr/pkg/include/DeviceKit   
-I/usr/pkg/include/dbus-1.0 -I/usr/pkg/lib/dbus-1.0/include 
-I/usr/pkg/include/glib/glib-2.0 -I/usr/pkg/lib/glib-2.0/include     
-I/usr/pkg/include -I/usr/include  -O2 -I/usr/pkg/include -I/usr/include -MT 
devkit_daemon-devkit-daemon.o -MD -MP -MF .deps/devkit_daemon-devkit-daemon.Tpo 
-c -o devkit_daemon-devkit-daemon.o `test -f 'devkit-daemon.c' || echo 
devkit-daemon.c: In function 'receive_drvctl_data':
devkit-daemon.c:415: error: 'DRVGETEVENT' undeclared (first use in this 
devkit-daemon.c:415: error: (Each undeclared identifier is reported only once
devkit-daemon.c:415: error: for each function it appears in.)
devkit-daemon.c: In function 'drvctl_enumerate':
devkit-daemon.c:787: error: storage size of 'laa' isn't known
devkit-daemon.c:850: error: 'DRVLISTDEV' undeclared (first use in this function)
gmake[1]: *** [devkit_daemon-devkit-daemon.o] Error 1
gmake[1]: Leaving directory 
gmake: *** [all] Error 2
*** Error code 2

make: stopped in /usr/pkgsrc/sysutils/devkitd

        Most probably just adjust the ONLY_FOR_PLATFORM spec so it
        doesn't even attempt to build < NetBSD 5 (or 5.99 perhaps)

        If his really was intended to work on NetBSD 4.0 then most likely
        some include file is missing - but I can't see any 4.0 include
        file that defines DRVGETEVENT

Home | Main Index | Thread Index | Old Index