pkgsrc-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

pkg/42072: xfce4 files and meta packages

>Number:         42072
>Category:       pkg
>Synopsis:       unneeded xfce4 buildlink3/mk files
>Confidential:   no
>Severity:       non-critical
>Priority:       low
>Responsible:    pkg-manager
>State:          open
>Class:          change-request
>Submitter-Id:   net
>Arrival-Date:   Wed Sep 16 02:55:00 +0000 2009
>Release:        NetBSD
Architecture: x86_64
Machine: amd64
xfce4 packages provide many files.
Most are not needed. They provide no "build" need.

Alos the meta packages for xfce4 and xfce4-extras
use many includes of the files
instead of using DEPENDS. These are not for a "build".

The meta packages should have DEPENDS instead and specifically
require the latest versions as appropriate.

So an example problem is that xfce4-4.6.1 may end up have old
dependencies so may not really represent 4.6.1.
Get rid of unneeded files.

Change XFCE4 packages to use DEPENDS to BUILD_DEPENDS
as appropriate.

Home | Main Index | Thread Index | Old Index