pkgsrc-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

www/zope211 and www/zope210 build error

Dear pkgsrc users / devels,

since several weeks i get an error while building or updating

both with the same error:

        "option --with-laguage not recognized"

python is (as required) python2.4

Any help is welcome - i will try to fiddle around for now...

--- snip ---
dr1:/usr/pkgsrc/www/zope211$ make
=> Bootstrap dependency digest>=20010302: found digest-20070803
=> Checksum SHA1 OK for Zope-2.11.2-final.tgz
=> Checksum RMD160 OK for Zope-2.11.2-final.tgz
===> Installing dependencies for zope211-2.11.2
The following variables will affect the build process of this package,
zope211-2.11.2.  Their current value is shown below:

        * BDB185_DEFAULT = db1
        * BDB_DEFAULT = db4
        * ZOPE_VERSION = 211

Based on these variables, the following variables have been set:

        * BDBBASE = /usr
        * BDB_LIBS (defined, but empty)
        * BDB_TYPE = db1
        * PYPACKAGE = python24
        * ZOPE_PKG = zope211

You may want to abort the process now with CTRL-C and change their value
before continuing.  Be sure to run `/usr/bin/make clean' after
the changes.
=> Full dependency py24-expat>=0: found py24-expat-0nb4
=> Full dependency python24>=2.4.2nb4: found python24-2.4.5nb2
===> Overriding tools for zope211-2.11.2
===> Extracting for zope211-2.11.2
cd /usr/pkgsrc/www/zope211/work/Zope-2.11.2-final; /usr/bin/find doc lib 
skel/import -type f -print |  /usr/bin/xargs /bin/chmod -x
===> Patching for zope211-2.11.2
/bin/cp ../zope/files/ 
/bin/rm -f 
=> Applying pkgsrc patches for zope211-2.11.2
===> Creating toolchain wrappers for zope211-2.11.2
===> Configuring for zope211-2.11.2
=> Fixing some parameters in files.
=> Update to zope211
=> Replacing python interpreter in lib/python/Zope2/Startup/ 
lib/python/zdaemon/ lib/python/zdaemon/
=> Replacing python interpreter in lib/python/Zope2/Startup/ 
lib/python/zdaemon/ lib/python/zdaemon/

Using Python interpreter at /usr/pkg/bin/python2.4
option --with-laguage not recognized

./inst/ configures and writes a Makefile for Zope.

Defaults for options are specified in brackets.


  -h, --help                    display this help and exit


  --quiet                       suppress nonessential output

  --ignore-zlib                 allow configuration to proceeed if
                                Python zlib module is not found.

  --ignore-largefile            allow configuration to proceed without
                                Python large file support.

  --ignore-expat                allow configuration to proceed if the expat
                                XML parsing module is not found.

  --optimize                    compile Python files as .pyo files
                                instead of as .pyc files

  --no-compile                  don't compile Python files


  --build-base=DIR              use DIR to store temporary build files

  --prefix=DIR                  install Zope files in DIR [/opt/Zope-2.11]

By default, 'make install' will install Zope software files in
'/opt/Zope-2.11'  You can specify an alternate location for these
files by using '--prefix', for example: '--prefix=$HOME/zope'.

*** Error code 1

make: stopped in /usr/pkgsrc/www/zope211
*** Error code 1

make: stopped in /usr/pkgsrc/www/zope211
--- snap ---

Same happen on zope210.

I've tried to find the "--with-laguage" option within the pkgsrc system or 
within the Zope tree - but with no luck.

best regards,




  Niels Dettenbach
  Syndicat IT&Internet
  T.-Muentzer.-Str. 2, 37308 Heilbad Heiligenstadt - DE
  PGP public key ID 651CA20D
  Fingerprint: 55E0 4DCD B04C 4A49 1586  88AE 54DC 4465 651C A20D

Home | Main Index | Thread Index | Old Index