pkgsrc-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

pkg/41943: readline 6.0 is GPLv3.

>Number:         41943
>Category:       pkg
>Synopsis:       readline 6.0 is GPLv3.
>Confidential:   no
>Severity:       serious
>Priority:       medium
>Responsible:    pkg-manager
>State:          open
>Class:          change-request
>Submitter-Id:   net
>Arrival-Date:   Wed Aug 26 15:20:01 +0000 2009
>Originator:     Takahiro Kambe
>Release:        NetBSD 5.99.15
Takahiro Kambe
System: NetBSD 5.99.15 NetBSD 5.99.15 (GENERIC) #260: Sun 
Aug 9 15:19:08 JST 2009 i386
Architecture: i386
Machine: i386
        Current devel/readline package is readline 6.0 in pkgsrc and
        its license is GPLv3.

        Since current devel/readline/Makefile's LICENSE is gnu-gpl-v2,
        we need to change to gnu-gpl-v3.

        But GPLv3 itself has license incompatibility problem.


        So, strict view from license, we keep old readline package which
        is readlly gnu-gpl-v2.



Home | Main Index | Thread Index | Old Index