pkgsrc-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

pkg/41357: apache package should probably depend on libexpat

>Number:         41357
>Category:       pkg
>Synopsis: not found when starting apache
>Confidential:   no
>Severity:       serious
>Priority:       low
>Responsible:    pkg-manager
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Tue May 05 12:45:00 +0000 2009
>Release:        NetBSD 5.0
System: NetBSD 5.0 NetBSD 5.0 (XEN3_DOMU) #0: Sun 
Apr 26 06:44:24 UTC 2009
Architecture: x86_64
Machine: amd64
looks like maybe libexpat should be a dependency for the apache package?

pkg_add apache binary package onto a clean system and try to start it.

nibbler% /etc/rc.d/apache start                                                
Starting apache.
Shared object "" not found

have the package depend on libexpat (most likely)
configure the package so it does not depend on libexpat (probably not)

Home | Main Index | Thread Index | Old Index