pkgsrc-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

pkg/41150: misc/openoffice3 package links against installed package

>Number:         41150
>Category:       pkg
>Synopsis:       misc/openoffice3 package links against installed package
>Confidential:   no
>Severity:       serious
>Priority:       medium
>Responsible:    pkg-manager
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Sun Apr 05 17:55:00 +0000 2009
>Originator:     Gary Duzan
>Release:        NetBSD 5.0_RC2
System: NetBSD capo 5.0_RC2 NetBSD 5.0_RC2 (CAPO64) #132: Sat Feb 14 23:36:29 
EST 2009 gary@capo:/usr/obj/sys/arch/amd64/compile.amd64/CAPO64 amd64
Architecture: x86_64
Machine: amd64
        A build of misc/openoffice3 with an installed openoffice3 already in 
        attempts to link against the installed libraries instead of the ones in 
        I was doing a rolling replace build, where icu was one of the packages
        replaced, and openoffice3 was a dependency. The build failed because the
        existing openoffice3 libraries were linked against the older, no longer
        existing icu libraries, and the build was trying to link against them:

ld: warning:, needed by 
 not found (try using -rpath or -rpath-link)
 undefined reference to `uscript_getScript_3_6'

        Unknown. Workaround is to uninstall misc/openoffice3 before the build.

Home | Main Index | Thread Index | Old Index