pkgsrc-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

pkg/41071: inputmethod/uim fails to build with "gnome" option

>Number:         41071
>Category:       pkg
>Synopsis:       inputmethod/uim fails to build with "gnome" option
>Confidential:   no
>Severity:       serious
>Priority:       medium
>Responsible:    pkg-manager
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Wed Mar 25 02:35:00 +0000 2009
>Originator:     Ryo HAYASAKA
>Release:        NetBSD 5.99.8, pkgsrc-current
Japan Advanced Institute of Science and Technology (JAIST)
System: NetBSD 5.99.8 NetBSD 5.99.8 (MONOLITHIC) #46: Wed 
Mar 25 07:28:31 JST 2009 i386
Architecture: i386
Machine: i386
$ make
=> Bootstrap dependency digest>=20010302: found digest-20080510
=> Checksum SHA1 OK for uim-1.5.5.tar.bz2
=> Checksum RMD160 OK for uim-1.5.5.tar.bz2
===> depends-message [uim-1.5.5] ===> Installing dependencies for uim-1.5.5
The supported build options for uim are:

        anthy canna eb gnome gtk kde m17nlib prime
        qt uim-fep xim

The currently selected options are:

        anthy canna gnome gtk m17nlib qt uim-fep xim

You can select which build options to use by setting PKG_DEFAULT_OPTIONS
or the following variable.  Its current value is shown:

        PKG_OPTIONS.uim (not defined)

The following variables will affect the build process of this package,
uim-1.5.5.  Their current value is shown below:

        * FAM_DEFAULT = fam

Based on these variables, the following variables have been set:

        * FAMBASE (defined, but empty)
        * FAM_TYPE = fam

You may want to abort the process now with CTRL-C and change their value
before continuing.  Be sure to run `/usr/bin/make clean' after
the changes.
=> Build dependency libtool-base>=1.5.18nb5: found libtool-base-1.5.26nb1
=> Build dependency intltool>=0.40.0: found intltool-0.40.6
=> Build dependency gmake>=3.81: found gmake-3.81
=> Build dependency perl>=5.0: found perl-5.10.0nb5
=> Build dependency pkg-config>=0.19: found pkg-config-0.23
=> Build dependency x11-links>=0.43: found x11-links-0.43
=> Build dependency qt3-tools>=3.3.6nb1: found qt3-tools-3.3.8nb3
=> Build dependency checkperms>=1.1: found checkperms-1.10
=> Full dependency xdg-dirs>=1.1: found xdg-dirs-1.4
=> Full dependency ncurses>=5.4nb1: found ncurses-5.7nb1
=> Full dependency anthy>=7900: found anthy-9100
=> Full dependency Canna-lib>=3.6pl4: found Canna-lib-3.6pl4nb2
=> Full dependency gnome-panel>=2.22.2nb1: found gnome-panel-2.26.0
=> Full dependency gtk2+>=2.8.17nb1: found gtk2+-2.16.0nb1
=> Full dependency m17n-lib>=1.5.1: found m17n-lib-1.5.3
=> Full dependency qt3-libs>=3.3.6nb1: found qt3-libs-3.3.8nb8
=> Full dependency libgcroots>=0.2.1: found libgcroots-0.2.1
===> tools-message [uim-1.5.5] ===> Overriding tools for uim-1.5.5
mv -f .deps/uim_toolbar_applet-toolbar-common-gtk.Tpo 
cc -DHAVE_CONFIG_H -I. -I../uim -I../replace -I../uim -I.. -I/usr/pkg/include 
-I/usr/X11R7/include -I/usr/include -I/usr/pkg/include/nss 
-I/usr/pkg/include/nspr -I/usr/pkg/include/db4 -I/usr/X11R7/include/freetype2 
-I/usr/pkg/qt3/include -D_REENTRANT -I/usr/pkg/include/gtk-2.0 
-I/usr/pkg/lib/gtk-2.0/include -I/usr/pkg/include/atk-1.0 
-I/usr/pkg/include/cairo -I/usr/pkg/include/pango-1.0 -I/usr/X11R7/include 
-I/usr/pkg/include/glib/glib-2.0 -I/usr/pkg/lib/glib-2.0/include 
-I/usr/X11R7/include/pixman-1 -I/usr/X11R7/include/freetype2 -I/usr/pkg/include 
-I/usr/pkg/include/libpng12    -Wall -O2 -pipe -mfpmath=sse -msse3 
-march=athlon64 -I/usr/pkg/include -I/usr/X11R7/include -I/usr/include 
-I/usr/pkg/include/nss -I/usr/pkg/include/nspr -I/usr/pkg/include/db4 
-I/usr/X11R7/include/freetype2 -I/usr/pkg/qt3/include -pedantic -Wall 
-Wchar-subscripts -Wmissing-declarations -Wredundant-decls -Wmissing-prototypes 
-Wnested-externs -Wpointer-arith -Wcast-align -Wsign-compare -Wno-long-long 
 -DNDEBUG -Wno-error -MT uim_candwin_gtk-candwin-gtk.o -MD -MP -MF 
.deps/uim_candwin_gtk-candwin-gtk.Tpo -c -o uim_candwin_gtk-candwin-gtk.o `test 
-f 'candwin-gtk.c' || echo './'`candwin-gtk.c
toolbar-applet-gnome.c:41:19: error: gnome.h: No such file or directory
toolbar-applet-gnome.c:86: warning: string length '966' is greater than the 
length '509' ISO C89 compilers are required to support
toolbar-applet-gnome.c: In function 'display_about_dialog':
toolbar-applet-gnome.c:164: warning: implicit declaration of function 
toolbar-applet-gnome.c:164: warning: nested extern declaration of 
toolbar-applet-gnome.c:171: warning: assignment makes pointer from integer 
without a cast
gmake[1]: *** [uim_toolbar_applet-toolbar-applet-gnome.o] Error 1
gmake[1]: *** Waiting for unfinished jobs....
mv -f .deps/uim_candwin_gtk-candwin-gtk.Tpo .deps/uim_candwin_gtk-candwin-gtk.Po
gmake[1]: Leaving directory `/usr/pkgsrc/inputmethod/uim/work/uim-1.5.5/helper'
gmake: *** [all-recursive] Error 1
*** Error code 2

make: stopped in /usr/pkgsrc/inputmethod/uim
*** Error code 1

make: stopped in /usr/pkgsrc/inputmethod/uim

Home | Main Index | Thread Index | Old Index