pkgsrc-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

pkg/40767: net/vncviewer can't download its source anymore

>Number:         40767
>Category:       pkg
>Synopsis:       net/vncviewer can't download its source anymore
>Confidential:   no
>Severity:       serious
>Priority:       medium
>Responsible:    pkg-manager
>State:          open
>Class:          change-request
>Submitter-Id:   net
>Arrival-Date:   Fri Feb 27 12:30:00 +0000 2009
>Originator:     Jörn Clausen
>Release:        NetBSD 4.0.1
University of Bielefeld
NetBSD hrzkpgsrc 4.0.1 NetBSD 4.0.1 (GENERIC) #0: Tue Oct  7 22:58:48 PDT 2008  

net/vncviewer defines a pre-fetch target to download the sources. It uses 
FETCH_CMD, which seems not to be defined by default any more:

test -f /usr/pkgsrc/distfiles/vnc-4_1_2-unixsrc.tar.gz ||  (cd 
/usr/pkgsrc/distfiles &&  -o vnc-4_1_2-unixsrc.tar.gz\?product=free4/src/unix\&acceptLicense=1\&filever=4.1.2\&filetype=tar_gz\&haveDetails=1)
-o: not found

make sure, ${DISTNAME}.tar.gz is not in ${DISTDIR}, then "make"
Although this can probably be fixed, I suggest to ask the user to download the 
archive manually (like e.g. in lang/sun-*). If the distributor imposes these 
restrictions (even if the license is GPL), and the user still wants to use that 
particular software, he has to suffer.

Home | Main Index | Thread Index | Old Index