pkgsrc-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

pkg/40765: graphviz-2.20.3 does not configure

>Number:         40765
>Category:       pkg
>Synopsis:       graphviz-2.20.3 does not configure
>Confidential:   no
>Severity:       serious
>Priority:       medium
>Responsible:    pkg-manager
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Fri Feb 27 08:55:01 +0000 2009
>Originator:     Jörn Clausen
>Release:        NetBSD 4.0.1
University of Bielefeld
NetBSD hrzkpgsrc 4.0.1 NetBSD 4.0.1 (GENERIC) #0: Tue Oct  7 22:58:48 PDT 2008  

graphics/graphviz bails out in the configure step:

checking for gmsgfmt... /usr/bin/msgfmt
checking for xgettext... /usr/bin/xgettext
./configure.lineno: cannot open ./po/ no such file
./configure.lineno: 34820: Syntax error: Bad substitution
*** Error code 2

make: stopped in /usr/pkgsrc/graphics/graphviz
WARNING: *** Please consider adding fortran to USE_LANGUAGES in the package 
*** Error code 1

make: stopped in /usr/pkgsrc/graphics/graphviz

This is the error in config.log:

configure:34393: checking for xgettext
configure:34420: result: /usr/bin/xgettext
configure:34449: cc -o conftest -O2 -I/usr/pkg/include -I/usr/include -I/usr/pkg
/include/freetype2 -Wno-unknown-pragmas -Wstrict-prototypes -Wpointer-arith -Wal
l -ffast-math -DNO_POSTSCRIPT_ALIAS=1 -I/usr/pkg/include -I/usr/include -I/usr/p
kg/include/freetype2 -I/usr/pkg/include -L/usr/pkg/lib -Wl,-R/usr/pkg/lib -L/usr
/lib -Wl,-R/usr/lib -L/usr/pkg/lib conftest.c  -lintl  >&5
conftest.c:10:1: warning: "NO_POSTSCRIPT_ALIAS" redefined
<command line>:1:1: warning: this is the location of the previous definition
conftest.c:106: warning: function declaration isn't a prototype
configure:34455: $? = 0



Home | Main Index | Thread Index | Old Index