pkgsrc-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: pkg/40592: Trouble with plperl and plpythonu

The following reply was made to PR pkg/40592; it has been noted by GNATS.

From: David Holland <>
Subject: Re: pkg/40592: Trouble with plperl and plpythonu
Date: Sun, 15 Feb 2009 02:30:50 +0000

 On Mon, Feb 09, 2009 at 05:40:00PM +0000, 
  > >Synopsis:       Trouble with plperl and plpythonu
  > >Release:        4.0.1
  > postgresql command 
  > createlang -U pgsql plpythonu template1
  > fails with the message
  > "createlang: language installation failed: server closed the
  > connection unexpectedly"
  > [...]
  > If the server is built with lines 34-36 of
  > pkgsrc/databases/postgresql8x-server/Makefile commented out then
  > plpythonu can be installed.
  > Lines are:
  > .if ${OPSYS} == "NetBSD"
  > .endif
  > As far as I can make out this was added to fix a problem in 2.x
  > which resulted in going to 100% cpu under certain circumstances.
 This does not happen for me in netbsd-5, which leads me to suspect
 that the real problem is the netbsd-4 pthreads library.
 Your best approach is probably to use netbsd-5, which is, though not
 yet released, very close to it. Switching from 4.0.1 to 4.1_STABLE
 might also help.
 (The pthreads fixes in 4.1_STABLE are too invasive to go into 4.0.x,
 and 3.1 will be EOL when 5.0 is released.)
 David A. Holland

Home | Main Index | Thread Index | Old Index