pkgsrc-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

pkg/40619: mjpegtools build fails

>Number:         40619
>Category:       pkg
>Synopsis:       mjpegtools build fails
>Confidential:   no
>Severity:       non-critical
>Priority:       high
>Responsible:    pkg-manager
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Wed Feb 11 21:05:00 +0000 2009
>Originator:     Bernd Ernesti
>Release:        NetBSD 3
System: NetBSD 3
Architecture: i386
Machine: i386
        Since the update of mjpegtools to 1.9.0 the build fails with gcc 3.3.3:

        Making all in yuvdeinterlace
gmake[2]: Entering directory 
c++ -DHAVE_CONFIG_H -I. -I.. -I.. -I../utils  -I/usr/pkg/include -I/usr/include 
 -O2 -I/usr/pkg/include -I/usr/include  -pthread   -MT yuvdeinterlace.o -MD -MP 
-MF .deps/yuvdeinterlace.Tpo -c -o yuvdeinterlace.o error: invalid use of `restrict'
gmake[2]: *** [yuvdeinterlace.o] Error 1

        cd multimedia/mjpegtools

Home | Main Index | Thread Index | Old Index