pkgsrc-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

pkg/40546: "pkg_install" doesn't build under Mac OS X

>Number:         40546
>Category:       pkg
>Synopsis:       "pkg_install" doesn't build under Mac OS X
>Confidential:   no
>Severity:       serious
>Priority:       medium
>Responsible:    pkg-manager
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Tue Feb 03 10:20:00 +0000 2009
>Originator:     Matthias Scheler
>Release:        Darwin 9.6.0 2009-02-03 pkgsrc HEAD
Matthias Scheler                        
System: Darwin 9.6.0 Darwin Kernel Version 9.6.0: Mon 
Nov 24 17:39:01 PST 2008; root:xnu-1228.9.59~1/RELEASE_PPC Power Macintosh
Architecture: powerpc
Machine: Power Macintosh
The latest version of "pkg_install" doesn't build under Mac OS X:

gcc -L/Users/tron/obj/pkgtools/pkg_install/work.excalibur/libarchive/.libs 
-L/Users/tron/obj/pkgtools/pkg_install/work.excalibur/libnbcompat -L/usr/lib 
-L/usr/pkg/lib -L../lib -o pkg_info main.o perform.o show.o -linstall -larchive 
-lfetch -lbz2 -lz -ltermcap -lnbcompat
Undefined symbols:
  "_fetch_flags", referenced from:
      _fetch_flags$non_lazy_ptr in libinstall.a(pkg_io.o)
ld: symbol(s) not found
collect2: ld returned 1 exit status
*** Error code 1

It looks like a problem caused by an undefined symbol that an ELF linker
doesn't detect.

cd pkgsrc/pkgtools/pkg_install

None provided.

Home | Main Index | Thread Index | Old Index