pkgsrc-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

pkg/40329: autoconf 2.63 doesn't build on MacOS 10.3.9

>Number:         40329
>Category:       pkg
>Synopsis:       autoconf 2.63 doesn't build on MacOS 10.3.9
>Confidential:   no
>Severity:       non-critical
>Priority:       low
>Responsible:    pkg-manager
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Mon Jan 05 15:20:00 +0000 2009
>Originator:     Ignatios Souvatzis
>Release:        MacOS 10.3.9, pkgsrc 2008Q4 or later
Darwin mugomo.local 7.9.0 Darwin Kernel Version 7.9.0: Wed Mar 30 20:11:17 PST 
2005; root:xnu/xnu-517.12.7.obj~1/RELEASE_PPC  Power Macintosh powerpc
Architecture: powerpc
Machine: MacMini
Xcode: 1.5


=> Bootstrap dependency digest>=20010302: found digest-20080510
===> Skipping vulnerability checks.
WARNING: No /Volumes/Shared/pkgdb/pkg-vulnerabilities file found.
WARNING: To fix run: `/Volumes/Shared/pkg/sbin/download-vulnerability-list'.
=> Checksum SHA1 OK for autoconf-2.63.tar.bz2
=> Checksum RMD160 OK for autoconf-2.63.tar.bz2
===> Installing dependencies for autoconf-2.63
=> Full dependency perl>=5.8.0: found perl-5.10.0nb4
===> Overriding tools for autoconf-2.63
===> Extracting for autoconf-2.63
===> Patching for autoconf-2.63
===> Creating toolchain wrappers for autoconf-2.63
===> Configuring for autoconf-2.63
=> Modifying GNU configure scripts to avoid --recheck
=> Replacing config-guess with pkgsrc versions
=> Replacing config-sub with pkgsrc versions
=> Replacing install-sh with pkgsrc version
configure: WARNING: If you wanted to set the --build type, don't use --host.
    If a cross compiler is detected then cross compile mode will be used.
checking for a BSD-compatible install... /usr/bin/install -c -o root -g wheel


config.status: creating bin/Makefile
config.status: executing tests/atconfig commands
===> Building for autoconf-2.63
/Volumes/Shared/pkg/bin/bmake  all-recursive
AUTOM4TE_CFG='../lib/autom4te.cfg'         ../bin/autom4te      -B '..'/lib -B 
'..'/lib --language M4sh --cache '' --melt ./ -o /usr/bin/gm4: Warning: Excess arguments to built-in `_m4_popdef' 
autom4te: /usr/bin/gm4 failed with exit status: 1
*** Error code 1

bmake: stopped in /Volumes/Shared/pkgsrc/devel/autoconf/work/autoconf-2.63/bin
*** Error code 1

bmake: stopped in /Volumes/Shared/pkgsrc/devel/autoconf/work/autoconf-2.63
*** Error code 1

        This is reproducable with:

        - complete pkgsrc-2008Q4
        - complete pkgsrc-2008Q3, but -current devel/autoconf
        - complete pkgsrc-2008Q3, but 2008Q4 devel/autoconf

        Workaround: revert to autoconf-2.62, e.g. by
        cd devel/autoconf; cvs update -Pdrpkgsrc-2008Q3

Home | Main Index | Thread Index | Old Index