pkgsrc-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

pkg/40230: "libvolume_id" doesn't build under Mac OS X

>Number:         40230
>Category:       pkg
>Synopsis:       "libvolume_id" doesn't build under Mac OS X
>Confidential:   no
>Severity:       serious
>Priority:       low
>Responsible:    pkg-manager
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Fri Dec 19 18:30:00 +0000 2008
>Originator:     Matthias Scheler
>Release:        Darwin 9.6.0
Matthias Scheler                        
System: Darwin 9.6.0 Darwin Kernel Version 9.6.0: Mon 
Nov 24 17:39:01 PST 2008; root:xnu-1228.9.59~1/RELEASE_PPC Power Macintosh
Architecture: Power Macintosh
Machine: powerpc
The "libvolume_id" package doesn't build under Mac OS X which breaks the
build of the "hal" package:

=> Bootstrap dependency digest>=20010302: found digest-20080510
===> Building for libvolume_id-0.81.0
  CC       ext.o
In file included from ext.c:27:
util.h:33:20: error: endian.h: No such file or directory
util.h:34:22: error: byteswap.h: No such file or directory
gnumake: *** [ext.o] Error 1
*** Error code 2

bmake: stopped in /usr/pkgsrc/devel/libvolume_id
*** Error code 1

cd pkgsrc/sysutils/hal
bmake install

None known.

Home | Main Index | Thread Index | Old Index