pkgsrc-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

pkg/40075: imap-uw needs dummy.h in PLIST to build php-imap

>Number:         40075
>Category:       pkg
>Synopsis:       imap-uw needs dummy.h in PLIST to build php-imap
>Confidential:   no
>Severity:       non-critical
>Priority:       medium
>Responsible:    pkg-manager
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Mon Dec 01 09:30:01 +0000 2008
>Originator:     Andri Piik
>Release:        SunOS 5.10 sparc
SunOS tar-067 5.10 Generic_125100-10 sun4u sparc SUNW
The problem occurs on Solaris 10. I get in php-imap package configure phase the 
following error

checking for U8T_CANONICAL... no
configure: error: utf8_mime2text() has new signature, but
U8T_CANONICAL is missing. This should not happen. Check config.log for
additional information.
*** Error code 1

imap-uw mk.conf flags:

ABI=                    32
PKGSRC_COMPILER=        sunpro
PKG_OPTIONS.imap-uw=ssl inet6 imapuw-cleartextpwd -imapuw-whoson
CFLAGS+=                -xarch=sparc -xO3              
CXXFLAGS+=              -xarch=sparc -xO3

Use Solaris 10, sunpro compiler (Sun Studio). And try to build php-imap.
Adding include/c-client/dummy.h to mail/imap-uw package PLIST fixes this issue 
(at least on Solaris 10).

Home | Main Index | Thread Index | Old Index