pkgsrc-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

pkg/40032: devel/meld (1.2.1) compile (python compile) error

>Number:         40032
>Category:       pkg
>Synopsis:       devel/meld (1.2.1) compile (python compile) error
>Confidential:   no
>Severity:       non-critical
>Priority:       medium
>Responsible:    pkg-manager
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Wed Nov 26 13:05:00 +0000 2008
>Originator:     Robert Elz
>Release:        NetBSD 4.0_STABLE (pkgsrc current within past 6 hours)
        Prince of Songkla University
System: NetBSD 4.0_STABLE NetBSD 4.0_STABLE 
(JADE-1.696-20080517) #9: Fri May 23 18:55:13 ICT 2008 i386
Architecture: i386
Machine: i386
        devel/meld generates a python syntax error compiling

        My pkgsrc picked pthyon 2.4 to se for this.

        I use pkg_comp and libkver with NetBSD 4.0 release sets installed
        and libkver simulating a 4.0 kernel version.  No 4.0 X sets installed,
        X11_TYPE=modular in (the sandbox) mk.conf.   I can't imagine any of
        this is relevant for this problem.

        Building /dev/meld results in ...

The following variables will affect the build process of this package,
meld-1.2.1.  Their current value is shown below:


Based on these variables, the following variables have been set:

        * PYPACKAGE = python24


/usr/pkg/bin/python2.4 -O -c 'import compileall; compileall.compile_dir("/usr/pk
Listing /usr/pkg/lib/meld ...
Compiling /usr/pkg/lib/meld/ ...
Compiling /usr/pkg/lib/meld/ ...
Compiling /usr/pkg/lib/meld/ ...
  File "/usr/pkg/lib/meld/", line 571
    self.textview[1 if len(files) >= 2 else 0].grab_focus()
SyntaxError: invalid syntax

Compiling /usr/pkg/lib/meld/ ...
Compiling /usr/pkg/lib/meld/ ...


=> Running POST-INSTALL script actions
pkg_create: can't stat `/usr/pkg/lib/meld/filediff.pyc'
pkg_create: can't stat `/usr/pkg/lib/meld/filediff.pyo'
=> Registering installation for meld-1.2.1
pkg_admin: meld-1.2.1: File `/usr/pkg/lib/meld/filediff.pyc' is in +CONTENTS but
 not on filesystem!
pkg_admin: meld-1.2.1: File `/usr/pkg/lib/meld/filediff.pyo' is in +CONTENTS but
 not on filesystem!
meld-1.2.1 requires installed package gnome2-dirs-1.6
meld-1.2.1 requires installed package py24-gnome2-2.22.3
meld-1.2.1 requires installed package py24-gtk2-2.13.0nb1
meld-1.2.1 requires installed package python24-2.4.5nb2
meld-1.2.1 requires installed package rarian-0.8.1
meld-1.2.1 requires installed package xdg-dirs-1.4
=> Checking file-check results for meld-1.2.1
ERROR: ************************************************************  
ERROR: The following files are in the PLIST but not in /usr/pkg:
ERROR:         /usr/pkg/lib/meld/filediff.pyc
ERROR:         /usr/pkg/lib/meld/filediff.pyo
*** Error code 1

make: stopped in /usr/pkgsrc/devel/meld
*** Error code 1


        The PLIST problem is just a side effect of the compile error
        I expect.

        Maybe this equires python 2.5?   Or perhaps it is just an
        error (I don't speak snake).

Home | Main Index | Thread Index | Old Index