[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]
The following reply was made to PR pkg/39890; it has been noted by GNATS.
From: Bernd Ernesti <veego%NetBSD.org@localhost>
Subject: Re: pkg/39890
Date: Fri, 21 Nov 2008 07:44:37 +0100
On Thu, Nov 20, 2008 at 11:00:06PM +0000, Michal Suchanek wrote:
> > Ruby programs are updated to supoprt newer Ruby 1.8.7 (or 1.9 preview).
> Yes. I do not doubt that. On the other hand, I have not heard of a
> program that requires 1.8.7. And code written for 1.8.7 (using 1.8.7
> documentation) has high chance of failing on 1.8.6 or earlier.
Code written for 1.8.6 have a much higher chance to fail once 1.9 is out.
With 1.8.7 you get warnings what you should avoid to get it working with
> > > On some platfroms ruby 1.8.7 is not available and it is not desirable
> to install this version for most Ruby users (as far as I can tell from the
> ML discussions).
> > What is the "some platfroms"
> "some platforms" include Windows, and probably packaging systems that
> are not as eager to pick bleeding edge stuff ;-)
So it is not for an OS which is supported by pkgsrc.
Btw, it it false that 1.8.7 is not supported on Windows.
See http://www.ruby-lang.org/en/downloads/ where you can get it.
Oh, and some packaging system still use an outdated version
with security problems.
> > and "the ML discussions"?
Provide a pointer to a URL with a statement from a ruby developer.
> > > >Fix:
> > > roll back ruby to 1.8.6 or provide a separate 1.8.6 package
> > Retiring ruby 1.8.7 to 1.8.6 pillage the use of functionality of Ruby
> > 1.8.7 and I don't think it is realistic approach.
> Packaging an incompatible version of the interpreter does not seem
> realistic either.
Where is it incompatible?
As mentioned above, you get more problems once 1.9 is out if you use
1.8.6 right now.
And on the url which i mentioned above you see:
The current stable version is 1.8.7.
So why should we go back to another legacy version?
Main Index |
Thread Index |