pkgsrc-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

pkg/39890: ruby 1.8.6 not available in pkgsrc

>Number:         39890
>Category:       pkg
>Synopsis:       ruby 1.8.6 not available in pkgsrc
>Confidential:   no
>Severity:       non-critical
>Priority:       medium
>Responsible:    pkg-manager
>State:          open
>Class:          change-request
>Submitter-Id:   net
>Arrival-Date:   Mon Nov 10 12:05:00 +0000 2008
>Originator:     hramrach
>Release:        NetBSD 4.99.73
System: NetBSD 4.99.73 NetBSD 4.99.73 (miniMac) #3: Mon Nov 3 15:40:22 CET 2008 
root@:/usr/src/sys/arch/i386/compile/miniMac i386
Architecture: i386
Machine: i386
 The Ruby 1.8.7 available in pkgsrc is not 1.8 compatible.
 While most 1.8 code runs in 1.8.7 with only minor tweaks lots of 1.8.7 code 
would not run in older 1.8 rubies which makes 1.8.7 completely unsuitable for 
Ruby development.
 On some platfroms ruby 1.8.7 is not available and it is not desirable to 
install this version for most Ruby users (as far as I can tell from the ML 
install ruby
roll back ruby to 1.8.6 or provide a separate 1.8.6 package


Home | Main Index | Thread Index | Old Index