pkgsrc-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

pkg/39839: cairo or pixman need revision bumps?

>Number:         39839
>Category:       pkg
>Synopsis:       pixman or cairo need revision bumps?
>Confidential:   no
>Severity:       serious
>Priority:       medium
>Responsible:    pkg-manager
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Fri Oct 31 13:10:00 +0000 2008
>Release:        NetBSD 4.0
  Jeremy C. Reed
Building gnash failed with:

ERROR: pixman>=0.12.0 pixman>=0.9.6 is not installed; can't buildlink 

This was caused because gnash doesn't include pixman. It does include 

I had previously installed:

pixman-0.10.0nb1 which provides /usr/pkg/lib/
cairo-1.6.4nb1 which uses
gtk2+-2.12.9 which uses
pango-1.18.4 which uses

Looks like cairo and maybe gtk2+ and maybe pango should have been bumped?

But pixman was updated many months ago. Cairo buildlink just changed.
Have good enough cairo, gtk2+, or pango installed with old pixman
installed and try to build something (like gnash) that needs cairo
or gtk2 or pango (but not pixman specifically).
Bump some PKGREVISION(s).


Home | Main Index | Thread Index | Old Index