pkgsrc-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

pkg/39806: net/hobbitmon builds incorrect (and uncorrected) perl path into script

>Number:         39806
>Category:       pkg
>Synopsis:       net/hobbitmon builds incorrect (and uncorrected) perl path 
>into script
>Confidential:   no
>Severity:       non-critical
>Priority:       low
>Responsible:    pkg-manager
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Sun Oct 26 10:00:00 +0000 2008
>Originator:     Robert Elz
>Release:        NetBSD 3.0 (NetBSD 3.0 RELEASE and pkgsrc current today)
        Prince of Songkla University
System: NetBSD 4.0_STABLE NetBSD 4.0_STABLE 
(JADE-1.696-20080517) #9: Fri May 23 18:55:13 ICT 2008 i386
Architecture: i386
Machine: i386
        The check-interpreter script that PKG_DEVELOPER=yes
        causes to be run when building binary packages found an error
        in net/hobbitmon

        I'm usimg NetBSD 3.0 via pkg_comp (with libkvber), but I can't
        see how that would be relevant to this problem (except that
        pkg_comp defaults PKG_DEVELOPER=yes which is what finds the problem).

        Build net/hobbitmon binary package with PKG_DEVELOPER=yes - after a
        "successful" compile and install, expect to see ...

Hobbit setup is complete.

You must configure your webserver for the Hobbit webpages and CGI-scripts.
A sample Apache configuration is in 

To start Hobbit, as the hobbit user run 
'/usr/pkg/hobbit/server/bin/ start'
To view the Hobbit webpages, go to
=> Automatic manual page handling
=> Generating post-install file lists
=> Running POST-INSTALL script actions
=> Registering installation for hobbit-4.0b6nb11
hobbit-4.0b6nb11 requires installed package fping-2.4b2nb1
hobbit-4.0b6nb11 requires installed package openldap-client-2.4.11
hobbit-4.0b6nb11 requires installed package pcre-7.8
hobbit-4.0b6nb11 requires installed package png-1.2.32
hobbit-4.0b6nb11 requires installed package rrdtool-1.3.4nb1
=> Checking file-check results for hobbit-4.0b6nb11
=> Checking for non-existent script interpreters in hobbit-4.0b6nb11
ERROR: [] The interpreter "/usr/bin/perl" of 
"/usr/pkg/hobbit/cgi-bin/" does not exist.
*** Error code 1

make: stopped in /usr/pkgsrc/net/hobbitmon
*** Error code 1

make: stopped in /usr/pkgsrc/net/hobbitmon

        I think there's some pkgsrc magic for fixing things like this.
        I expect it just needs to be turned on by someone who knows how.

Home | Main Index | Thread Index | Old Index