pkgsrc-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

pkg/39690: gst-plugins0.10-bad has incorrect PLIST on non-x86

>Number:         39690
>Category:       pkg
>Synopsis:       gst-plugins0.10-bad has incorrect PLIST on non-x86
>Confidential:   no
>Severity:       non-critical
>Priority:       medium
>Responsible:    pkg-manager
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Fri Oct 03 20:20:00 +0000 2008
>Originator:     Magnus Henoch
>Release:        NetBSD 4.99.72
System: NetBSD zemdatav 4.99.72 NetBSD 4.99.72 (IBOOK) #0: Sat Aug 23 00:43:57 
CEST 2008 magnus@zemdatav:/media/e/netbsd/obj/sys/arch/macppc/compile/IBOOK 
Architecture: powerpc
Machine: macppc
        When building gst-plugins0.10-bad 0.10.8, this scrolled by
        during configuration:

        configure: WARNING: Not building real plugin, only works on 32bit and 
64bit x86 platforms

        This later leads to:

=> Automatic manual page handling
pkg_create: can't stat `/usr/pkg/lib/gstreamer-0.10/'
=> Registering installation for gst-plugins0.10-bad-0.10.8
pkg_admin: gst-plugins0.10-bad-0.10.8: File 
`/usr/pkg/lib/gstreamer-0.10/' is in +CONTENTS but not on 
gst-plugins0.10-bad-0.10.8 requires installed package glib2-2.16.5
gst-plugins0.10-bad-0.10.8 requires installed package 
gst-plugins0.10-bad-0.10.8 requires installed package gstreamer0.10-0.10.20
gst-plugins0.10-bad-0.10.8 requires installed package liboil-0.3.15
=> Dropping ``root'' privileges.
===> Building binary package for gst-plugins0.10-bad-0.10.8
=> Becoming ``root'' to make su-package-all (/usr/pkg/bin/sudo)
=> Creating binary package 
pkg_create: can't stat `/usr/pkg/lib/gstreamer-0.10/'
pkg_create: lstat failed for file lib/gstreamer-0.10/ No such 
file or directory
*** Error code 2

        and a binary package can't be created.
        I suppose should be conditionally included in
        PLIST... not sure how, though.


Home | Main Index | Thread Index | Old Index