pkgsrc-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: pkg/39218: [NEW] devel/p5-PPI-XS

The following reply was made to PR pkg/39218; it has been noted by GNATS.

From: "OBATA Akio" <>
Subject: Re: pkg/39218: [NEW] devel/p5-PPI-XS
Date: Thu, 14 Aug 2008 21:33:22 +0900

 On Mon, 11 Aug 2008 03:35:04 +0900, Jens Rehsack <> 
 >  >  Why depend on p5-PPI>=1.203?
 >  >  In Makefile.PL:
 >  >  requires      ( 'PPI'                      => '0.845' );
 >  >
 >  >
 >  Because of this statement from the POD of the package:
 >   > Because the C implementations are linked to the perl versions of the same
 >  function, it is preferable to upgrade PPI::XS any time you do a major
 >  upgrade of PPI itself.
 >  I didn't try with any other version than 1.203 - so I can't be sure that the
 >  hint in the Makefile.PL is correct or simply outdated and/or forgotten to be
 >  increased.
 'major upgrade' probably means bump of following value:
 $PPI::XS_COMPATIBLE = '0.845'
 If it bump to greater than $PPI::XS::VERSION, p5-PPI-XS must be updated.
 On the other hand, 
 $PPI::XS::PM_COMPATIBLE = '0.844'
 If it bump to greater than $PPI::VERSION, p5-PPI must be updated.
 Those requirement should be noted in p5-PPI-XS/Makefile and p5-PPI/Makefile.
 "Of course I love NetBSD":-)
 OBATA Akio /

Home | Main Index | Thread Index | Old Index